Impossible to Play

After I finally managed to install the mod I came upon the fact that it is unplayable. All the words and images (descriptions) are missing in game. This makes it impossible to know the stats of everything and what it is your building. Is my game file corrupted or something?

Either it's corrupted or you have not properly set up Large Address Aware.

So how would I tell which one is the problem?

Start with trying to reapply Large Address Aware; read the installation instructions.

done LAA for sure, It works with ALLLLLLLL of my other mods, but SOTP still crashes saying it isn't enabled

I have deleted and reinstalled the mod countless times, as well as the base game just incase and still to no avail it continues to crash (it worked in v1.85 but in v1.86 it has not worked at all)

@Lavo Your newer mod file says it does not need a Large Address Aware...

This thread is outdated; 1.90 came after this thread was made, and it is as of that version that LAA is enabled by default, and thus people should not do it manually. I'm locking this thread to avoid confusion; if someone is having issues still please make a new thread.