Joined
Last Online
Recent Posts
posted in Feedback and Suggestions read more

Hello, because of problems with updating SoaSE to versions past 1.83, im stuck here. I can not find a download for a version of SotP that is compatible with that version of the game. Is it possible for me to get a compatible version of the mod and possible support older versions of the game below 1.85?


Looks like your connection to Sins of the Prophets Forum was lost, please wait while we try to reconnect.